Flash Sale for Premium Subscriptions

50% off annual premium licence subscription.

Get 50%off now

Published Directory only showing first entry

About Support Directory Published Directory only showing first entry

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2796
    Avatar for bmackintoshbmackintosh
    Member

    We’re running on version Church Admin Plugin v1.3940 and I had to update our shortcodes to remove the login requirement. The new published shortcode is:

    [church_admin type=address-list member_type_id=2 map=1 photo=1 loggedin=FALSE]

    The page is displaying, but only the first entry displays. When I choose the PDF download all entries appear.

    Public site is allnationscrc.org/new2014/new-public-directory

    PW is ‘####’ (password removed by moderator)

    #3998
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Hi there,
    I’ve removed your password in the post to protect personal data!
    Your theme is inserting tags in to the javascript that controls the directory swapping people and therefore killing it.
    There’s a post elsewhere on this type of issue
    https://wordpress.stackexchange.com/questions/101368/wordspress-add-p-into-my-javascripts

    I’ll remove the white spaces in the javascript and update to 1.3950 later today.
    You also need to add a Google map api key – which is free. A tutorial is here – https://www.churchadminplugin.com/tutorials/google-map-api/

    #3999
    Avatar for bmackintoshbmackintosh
    Member

    @andymoyle said:
    Hi there,
    I’ve removed your password in the post to protect personal data!
    Your theme is inserting tags in to the javascript that controls the directory swapping people and therefore killing it.
    There’s a post elsewhere on this type of issue
    https://wordpress.stackexchange.com/questions/101368/wordspress-add-p-into-my-javascripts

    I’ll remove the white spaces in the javascript and update to 1.3950 later today.
    You also need to add a Google map api key – which is free. A tutorial is here – https://www.churchadminplugin.com/tutorials/google-map-api/  

    Thanks for the reply. I will see if I can get the Theme updated/corrected.

    We had an API for Google Maps at one point…looks like Google is starting to charge for map usage.

    #4000
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    I’ve updated the plugin, so it shouldn’t go wrong anymore.
    You can get the theme author to add

    remove_filter( ‘the_content’, ‘wpautop’ );
    remove_filter( ‘the_excerpt’, ‘wpautop’ );
    To the functions.php file to stop it adding paragraph tags

    Google maps – you now need a credit card on the account
    https://cloud.google.com/maps-platform/user-guide

    From July 16th Google will be charging for maps – https://cloud.google.com/maps-platform/pricing/sheet/ but giving $200 free credit per month! So it will effectively still be free for up to 28,000 monthly views.

    #4347
    Avatar for bmackintoshbmackintosh
    Member

    Hi Andy – I’m running into a similar issue as I described above. On my page with the directory published the alphabetical listing is showing but you cannot click on any of the letters. Again the PDF and search options both work – so I am not sure if its an issue with our theme or something else. The link to the published directory is http://allnationscrc.org/new2014/new-public-directory/ (I can re-share the PW as needed). Please advise

    #4348
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Can you message me the password please. Thanks

    #4360
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Brian in your case WordPress changed a line break into a paragraph tag in the middle of some JavaScript that should make changing letters possible, breaking it. I’ve removed all line breaks in the code, so all should be good from the next update later today (14th Oct 2019)

    #4367
    Avatar for bmackintoshbmackintosh
    Member

    Thanks Andy – I will take a look today!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.