Lost prayer request archive

About Support Prayer Requests Lost prayer request archive

  • This topic is empty.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #3030
    Avatar for JonJon

    Help! Right at this time when we need prayer requests the most we’re having trouble with the page. It was working fine until just recently.

    Others complained that when they access the page, they often get only the latest prayer request, not the archive with the option to post a new request. At first I couldn’t duplicate the problem, but then it started happening to me as well.

    If I post a new request through the backend, it seems to fix the problem for a while, but then it reappears.

    I have the archive on our site under “Connect – FBF Announce.” Any suggestions much appreciated!

    Avatar for Andy MoyleAndy Moyle

    I’ve had a look.
    For some reason, the menu item which should goto https://www.fbfellowship.org/prayer-requests/ is then redirected the last prayer request. Instead of the archive page. You probably need to stop it caching. I tried deleting the cache on the archive page, which last 1refresh then started misbehaving.

    Deactivate the cache plugin and see if that helps!

    Avatar for JonJon

    Thanks for the quick response! I see I have this warning, which I think is new:

    WP Super Cache Warning!

    Your server is configured to show files and directories, which may expose sensitive data such as login cookies to attackers in the cache directories. That has been fixed by adding a file named index.html to each directory. If you use simple caching, consider moving the location of the cache directory on the Advanced Settings page.
    If you just installed WP Super Cache for the first time, you can dismiss this message. Otherwise, you should probably refresh the login cookies of all logged in WordPress users here by clicking the logout link below.
    The logout link will log out all WordPress users on this site except you. Your authentication cookie will be updated, but you will not be logged out.
    Dismiss | Logout

    Do I need to deal with that before I deactivate the plugin? Can I get by with no caching, or should I try to clean up and reactivate. Thanks for the help!

    Avatar for Andy MoyleAndy Moyle

    I did some speed tests on my site with tools.pingdom.com and other tools before using a cache plugin and afterwards. It made no difference!
    Using wpsmushit to optimise images made some difference.
    I’ve taken off cache plugins as a waste of time.

    The paragraph you put in is okay. What happens is that if someone had gone to yoursite.com/wp-content/uploads/2020/03 they would have seen a list of files, now they won’t/

    Try de-activating the cache plugin and deleting your browser cache to see if it fixes the problem.
    If not go to Dashboard>Settings>Permalinks and click save – that willclear up the htaccess file maybe to stp weird redirects (which is your issue – the archive prayer requests is being redirected to the latest prayer request)

    Avatar for JonJon

    Thanks so much! I’ve done all that and it seems to be working fine now.

    Avatar for JonJon

    Well, it did better for a while and now it’s acting up again, on numerous devices—several browsers on several Macs and PCs, old iPad and new iPad…. If anything else comes to mind please let me know, and I’ll keep experimenting.

    Avatar for Andy MoyleAndy Moyle

    Me too when I went on the site just now.
    Had a quick dig around.

    Found the issue!
    So you call your Prayer Requests archive menu item “FBF Announce”
    But you also have a blog post called “FBF Announce”
    Then your Permalinks structure (Dashboard>Settings>Permalinks) is set to Postname (always a bad way to do it when there are lots of posts, although not your issue!)

    So you have a WordPress engine fight on when ever anyone clicks on FBF Announce. Is it the post or the menu item and it seems nobody wins so it throws the last prayer request at you.

    Simplest solution Dashboad>Settings>Permalinks and go for “Month and Name” option and click “Save changes” and then it should permanently come good (although iOS devices have persistent browser caches!!!)

    Avatar for JonJon

    Thank you, thank you! I owe you big time.

    I simply deleted the post, as it was an experiment and not used, and it’s cleared up on my devices anyway. I’m reluctant to change the permalinks. Won’t that affect pages too and so links from other places? Or do the pages with the “month and name” setting leave off the date and appear as they do currently?

    I know UK is hit very hard with this virus and pray you and your congregation stay safe!

    Avatar for Andy MoyleAndy Moyle

    Thanks! Literally got a text from a junior doctor who thinks he has it – so do pray for Dr A.

    If you start postingregularly, do change the permalinks – WP remembers what the link was originally as redirects if needed – unless there’s a clash and it goes a bit bonkers!

    Avatar for JonJon

    Never mind. I went ahead and set as month and name as you suggested and see if makes no difference in my page names.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.