Flash Sale for Premium Subscriptions

50% off annual premium licence subscription.

Get 50%off now

Households or Members not shown in Directory

About Support Directory Households or Members not shown in Directory

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2890
    Avatar for Rich CoxRich Cox
    Participant

    Hi Andy,
    I’ve noticed on a few occasions that clicking through the members directory, either members or entire households do not show up.

    The way I’ve got round this is to go back into the household listing and move members around and then it seems to work.?!?!?

    I’ve just had another instance this morning where all 3 people in a household did not show up in the directory despite them all being church members. Again it was fixed by moving their locations within the household.

    Any ideas please? Just worried that with 150 odd members other’s might not be displayed in the directory.

    As a side note, they are always found if you search, but are not shown when clicking on the letter in the alphabet.

    Thanks Andy, much appreciated!
    Blessings,
    Rich.

    #4241
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    It’s to do with whether the head of household flag has been set. Whenever a household is edited, a check is made to see that it has been set. I’m not sure why it wouldn’t be set…
    i) import CSV
    ii) registering/editing via shortcode
    iii) Back end adding/editing
    I’ve checked and the check is made with each one. Bizarre

    If you reset the version under Settings, every household is fixed. Don’t forget to refresh the front end address list (link at the bottom of the directory)

    #4242
    Avatar for Rich CoxRich Cox
    Participant

    Many thanks for the quick reply…

    All the editing is done in the back end. When I originally set it up I imported a CSV of all our member details.

    Perhaps I’ll have a play with resetting the version number under settings as you suggest.

    I got caught out once with NOT refreshing the front end, so that’s a given now.

    Thanks Andy…
    Rich.

    #4282
    Avatar for Rich CoxRich Cox
    Participant

    Hi Andy,
    I’m still getting random members not showing up in the directory?!?!

    I’ve reset the version as you’ve suggested but that doesn’t help. The only thing that fixes it is manually going into every member setting and scrolling down to member type and re-selecting ‘member’ and saving. It doesn’t seem to follow any pattern either.

    Often I only find out when someone complains their listing is not in the directory.

    Any other suggestions?

    Thanks Andy, apart from that I think all is running really well thank you.
    Blessings,
    Rich.

    #4285
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    So it is the member type that is going wrong. The old bug was head of household, which is long fixed. And of course , people can edit their own household in the app. Will do some digging.

    #4286
    Avatar for Rich CoxRich Cox
    Participant

    Many thanks Andy.

    #4407
    Avatar for Rich CoxRich Cox
    Participant

    @andymoyle said:
    So it is the member type that is going wrong. The old bug was head of household, which is long fixed. And of course , people can edit their own household in the app. Will do some digging.  

    Hi Andy,
    I’m still getting occasional members not showing up in the directory. If I click on people, the number of members is correct and if I edit the specific person they are showing as a member but not showing in the directory.

    The fix I’ve found is simply to edit the ‘missing’ person, make no changes and simply press save and then the directory shows as correct.

    It’s not a case of refreshing the directory on the front end, that doesn’t help.

    Please help, this is driving me nuts! – Thank you.
    Kind Regards,
    Rich.

    If it helps… I have the faulty condition now with a missing member. What can I send you that might help? / Logon??

    #4408
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Better would be to refresh your DB and download and send it to me with the name of the missing person. Then I can see what is wrong with their record and diagnose better the issue!

    #4409
    Avatar for Rich CoxRich Cox
    Participant

    Many thanks Andy,

    Emailing you now.

    #4420
    Avatar for JonJon
    Participant

    For what it’s worth, I just discovered we’re having the same problem. (We discovered it when my pastor’s household stopped showing up of all people.) Hope there’s a fix.

    #4421
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    This one is proving hard to pin down!
    It must be when someone edits a household somehow – you are both app users, so I wondered if it was that – but no!

    So I have found if someone is moved into a new household (ie a teenager becoming an adult), head of household wasn’t assigned to that new household, so they disappear off the front end directory. That’s fixed for 2.5400.

    I have edit entry set to edit in the back end and that in some scenarios is messing up the people order for displaying a household in the back end but not the front end directory.

    I’m now going to test out editing with the [church_admin_register] and see if that is causing a problem.

    People order was getting messed up and sometimes head of household, so hopefully all is now fixed for 2.54

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.