Flash Sale for Premium Subscriptions

50% off annual premium licence subscription.

Get 50%off now

Databasing trouble? Rota and Calendar

About Support Calendar Databasing trouble? Rota and Calendar

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2646
    Avatar for GavinGavin
    Participant

    I installed your Wonderfully all encompassing plugin at the beginning of my foray into our new church website. We haven’t gone live as I’m slowly getting myself up to speed. I’ve now got to actually trying to fill in data into Rotas Events etc… but hit a problem.

    WordPress database error: [Unknown column ‘autocomplete’ in ‘field list’]
    INSERT INTO secc1_church_admin_rota_settings (rota_task,autocomplete,initials,rota_order,service_id) VALUES(“PA”,”1″,”0″,”1″,”a:1:{i:0;i:1;}”)

    This error comes up any time I try to “Add Job to Rota”.

    I am also having trouble with some calendar appointments appearing and some not, but one issue at a time.

    Thank you for this incredible work!

    regards
    Gavin

    #3529
    Avatar for GavinGavin
    Participant

    I should add that reading previous posts I thought it might be a database issue. I have tried removing the church_admin_version field and letting the update run again. This appears to have made no difference at all.

    #3530
    Avatar for GavinGavin
    Participant

    Apologies for the redundant post – I appear to have fixed it. Hopefully correctly.

    Using phpMyAdmin I have added the “Autocomplete” column to the table “church_admin_rota_settings”

    I set it as:
    Number 2,
    name: autocomplete
    Type: Int
    Length: 1
    Null: Yes
    Default: Null

    I have no idea if that is correct but it seems to work. I am now happily adding Rota jobs.

    #3531
    Avatar for GavinGavin
    Participant

    HELP…. :-) I’m still stuck. Clearly those were not the correct values to select. Autocomplete doesn’t autocomplete.

    #3533
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Sorry about that. Found a bug in my install script, which will be corrected in 0.913, where the autocomplete column isn’t corrected.
    You are nearly there – the default should be 0 not NULL.

    Autocomplete doesn’t work when you “click to edit” a table cell. It’ll only work if you edit a particular service by clicking edit on the left of the table.
    It’ll also only work if you have people stored in the directory too!

    #3536
    Avatar for GavinGavin
    Participant

    Hmmm, I am still struggling. I have populated some people into the directory already. None of the names come up when I edit the service.

    I Click edit on the left of the service dates under the Rota tab and enter a few letters as in your video but nothing. It will allow me to save any random characters and doesn’t check them at all.

    #3537
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    I think I’ve found the problem – it’s to do with prefixes (for Dutch), just testing the fix now

    #3538
    Avatar for GavinGavin
    Participant

    Did you make any headway with this? Just wondering where I am going wrong with being able to fill in the rotas.

    #3539
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    Have you updated to 0.913?
    If you have can you send me a db backup to clients at themoyles dot uk and I’ll see what the problem is for you and send it back.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.