Can not send bulk email; problem with sql

About Support Bulk email Can not send bulk email; problem with sql

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2630 Mark as solved
    Avatar for Josef
    Guest

    Hi thank you so much for the plugin; it is very helpful! :)

    Still since last update v0.0835

    Whenever I try to send a bulk email for a certain type of member this is the response:

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/grenzj/public_html/wp-content/plugins/church-admin/includes/email.php on line 647
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘)’ at line 1]
    SELECT email, first_name FROM wp_church_admin_people WHERE ()

    No email address found for SELECT email, first_name FROM wp_church_admin_people WHERE ()

    Any thoughts?

    Thank you so much!

    #3503
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    That’s been fixed now in the latest update!

    #3504
    Avatar for Josef
    Guest

    Thank you so much for all your help!! :D

    #3524
    Avatar for Josef
    Guest

    Hi, sorry for re opening this topic. but with update 0.901 and WP version 4.4.2 I’m not able to send anymore bulkemails with my SMTP settings.

    On the Send bulk email page, after selecting the person I want to send the email to, input the subject, the body, click send, nothing happens.

    Any clues?

    Thank you so much.

    #3525
    Avatar for Josef
    Guest

    Inspecting at the html it looks like the the send button is placed outside the form… don’t know if that is a bug or not…. :/

    #3527
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    No it’s not that. The old smtp settings were automatically transferred over – fixed for 0.906. Although worth checking the settings page that the smtp settings are saved.

    #3534
    Avatar for Josef
    Guest

    Hi, thanks for the help, but still not working.

    1.- Click on the option Type in names.
    2.- Type a person, wait for person option to display and click on it. Then the name appears on the field.
    3.- Write in the subject value, “Test”
    4.- From name I write in my name.
    5.- From email, I write the same as in the settings.
    6.- Write the boddy of the mail “test”
    7.- Leave checkbox “Send now” option enabled.
    8.- Click on “Send”.

    Nothing happens, No sign of the click event was processed. Confused

    Under settings I have already tried both SSL and none SSL options.

    #3535
    Avatar for Andy MoyleAndy Moyle
    Keymaster

    I’ve found a bug in the section that finds the email names when you use the “Type in names” option. Fixed it and will be uploading later tonight.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.