I've written a book!

friendsfoodgospelcoverI'm excited to announce that I have written a book - Friends, Food and the Gospel.
I lead a multi-cultural church and we have learnt how to reach people from different nations with the gospel through friendship and food! In the book, I teach on how to apply Jesus's words "Come follow me and I will make you fishers of men" as a team, how to make strong friendships, what hospitality really is and how to share the gospel effectively to people from different cultural settings. It's available in print and as an ebook in all countries... Buy on Lulu.com worldwide Buy on amazon.co.uk Buy on amazon.com


Support Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register sp_MemberList Members

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
New Install Several Bugs?
20th January 2017
2:25 pm
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

I have the latest WordPress 4.7.1 and installed Church Admin Plugin v1.092.
It looks good but I have several things that don't work.
1) On the member edit I am able to create Ministries and Small Groups and enter in the tick boxes but after a save they revert back to unticked. (Prayer Chain tick box works OK and saves)
2) Groups from the main menus brings up a blank page.
3) I have created a test Rota but the Autocomplete is not working when I fill it in from the edit page, the busy symbol starts after I enter 3 letters but never completes, I have tried with upper & lower case names Christian name and surname.
4) I have yet to get the email working so any tips on using my own server would be helpful.

I have a number of other plugins in use so to eliminate any conflicts I disabled them all and had the same issues.

I need to iron these out before I can use the plugin

Allen

20th January 2017
2:45 pm
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

Welcome to the forum!

1) I can't reproduce that error with a fresh install of Wordpress and the plugin downloaded from the repository via Add New.
I added a small group and a ministry on an edit people screen and encountered no issues.
Are the groups and ministries that you created visible on the group & ministry pages? If you email me a refreshed DB backup from the plugin main screen I'll be able to dig down and see if there is an issue.

2) Again I can't reproduce that error

Maybe try de-activate, delete and re-add the plugin - perhaps it was corrupted in install?

3) Autocomplete is broken in v1.092 as there were some changes to the Wordpress core. That'll be fixed in the next update of the plugin. At the moment you do indeed just get the busy signal and nothing ever happens.

4) The only conflicts that have been reported so far occur when other plugins/themes also use the Google map API, but in an outdated way or without an API key - that'll kill any google maps for both plugins.

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

20th January 2017
5:33 pm
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

Groups is not visible it brings up a blank page with just the menu
Ministries shows up the created ministries and can be edited on the ministries page

Deleted and reinstalled total 3 times 3 different ways and still no improvement

Original install from the WordPress plugin page.
Next install from the downloaded zip file
3rd install by uploading direct via ftp the unzipped archive

Interesting to note the two installs from the zip file have "Schedule" in the menus, but when the folder was uploaded by ftp this menu became "Rota" I understand this is the same but as the folder I uploaded was from the same zip it is puzzling

I am using "Twenty Twelve Child Theme" I have tried it without the "Child Theme" with no improvements

Have re-installed WordPress version 4.7.1,
I tried to locate an older version of Church Admin to try

My feeling is that the database is corrupt but I have no way of deleting it and creating new
I have sent the Database backup & a couple of screen-shots

21st January 2017
8:30 am
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

Rota/Schedule
US installs translates Rota as Schedule - although it appears that some Americans get confused by that!

I have looked at the database backup you sent me and some tables were missing, so it looks like the install was corrupted.

I have put a reset the church admin version number plugin at
https://www.churchadminplugin.com/wp-content/uploads/reset-church-admin.zip

which will mean it should go through the upgrade/install again to install those missing tables and then begin to work properly.

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

21st January 2017
10:52 am
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

Thanks Andy for your prompt response
Rota/Schedule I checked my Wordpress currently only has US English with no other options so I will have to live with it for now.

I installed the reset-church-admin plugin and activated it.
Opened it from the menu and got the message "Church admin version has been reset" but nothing changed
Church-admin still v1.092 shows I have the latest version, yet the reset is v1.094 a newer number.

I edited the version number in the church-admin index,php file to v1,90 and was able to upgrade from there but still the same NO GROUPS

What am I doing wrong

Maybe if you sent me a bare working database backup, would it restore the missing tables into my database?

21st January 2017
11:06 am
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

v1.094 is what I am currently working on at home - just copied the header into that reset plugin 😉
All that did was clear the version number, so the install script is run again to install tables.

Try the nuclear option below - deactivate and delete Church Admin, install and activate the delete church admin plugin and it will wipe all database tables and options associated with Church Admin.

https://www.churchadminplugin.com/wp-content/uploads/delete-church-admin.zip

Then deactivate and delete it and reinstall Church Admin.

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

21st January 2017
11:18 am
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

Thanks Andy
Did all that and reinstalled Church Admin only to find it the same and the database was intact with all the entries as before

21st January 2017
11:26 am
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

Do you have PHPMyAdmin on your server setup or CPanel?
You'll need to delete the tables manually and then do a search on church_admin% in the options table and delete all of those.

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

21st January 2017
12:40 pm
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

I don't have access to have PHPMyAdmin on my server, I will need to contact my hosting provider who is a member of our church. He makes daily backups of the server so another alternative would be to restore a backup from before the first install.

Do you think uploading a working database would cure my problem by overwriting the corrupt one?
If so i would appreciate if you could send me a bare database to work on.

I the meantime my hosting provider is unavailable but I will discuss the issue with him asap

Thanks

21st January 2017
5:15 pm
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

Well the only way to upload a clean backup is using PHPMyAdmin! So talk to him and I'll email you one!

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

23rd January 2017
9:53 am
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

Thanks Andy
A day off yesterday but I uninsulated Church Admin and had all the tables deleted, a fresh install created an empty database as expected and this time I was able to create small groups and the tick boxes in the people module now work as they should.
The Group Module still returns a Main Menu only followed by a Blank page as before.
Using the shortcode in a post produces the full Small Groups correctly so the details are in the database its just the Group module that does not display
I will send you the latest database backup for reference.
The only thing we can think of that may be a problem or not the PHP is not up to date ours is PHP Version : 5.3.5

My web hosting is willing and able to upload a clean database if you could send it to me
Thanks
Allen

23rd January 2017
11:13 am
Avatar
Admin
Forum Posts: 333
Member Since:
4th March 2015
sp_UserOfflineSmall Offline

Glad you got it partially working. I develop using PHP5.6.1 and have it working on a PHP 7 server too.
If the groups display in a shortcode, then there is no issue with the database.

In a while I'll email you the latest v1.094 to try to see if that fixes your issues.

If you find the plugin useful, please buy me a coffee for all the late nights working on it!

24th January 2017
4:01 pm
Avatar
Wirksworth, Derbyshire, UK
Member
Members
Forum Posts: 8
Member Since:
19th January 2017
sp_UserOfflineSmall Offline

I look forward to trying the latest version.
My web hosting has agreed to update the PHP in the near future.

I sorted the Schedule/Rota problem 🙂
There was no option to change to "English" UK in the Site Language selection "English US "was the only language available. I installed "WordPress Language" plugin and was able to install & select the "English UK" as the site Language with this plugin. I had to re-install Wordpress version 4.7.1–en_GB to get the English UK available in the Site Language options.

I deactivated and deleted "Church Admin" and reinstalled from the WordPress plugin page and my menu shows the "ROTA" tag.
Unfortunately the Groups tag still returns a blank page

Forum Timezone: Europe/London

Most Users Ever Online: 19

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Member Stats:

Guest Posters: 11

Members: 254

Moderators: 0

Admins: 1

Forum Stats:

Groups: 4

Forums: 11

Topics: 210

Posts: 774

Administrators: andymoyle: 333